Saltar al contenido

Foto

Ayuda 4 ejes continuo CAMWORKS


  • Please log in to reply
27 Respuesta(s) a este Tema

#1
Andrés

Andrés

    Principiante en AuxCAD

  • Miembros
  • 6 Mensajes
  • Auxis: 0
    Buenos días,

    Escribo porque despues de renegar días enteros, y leer todo lo que he encontrado relativo a mecanizado con 4to eje, aún no logro dar en la tecla.

    El problema es el siguiente: nunca he mecanizado piezas con 4 ejes continuos en camworks, ahora lo necesito, y sinceramente, el programa hace lo que quiere conmigo...

    Mi idea original era desbastar y luego terminar la pieza con 4 ejes continuos, pero después de leer sus recomendaciones he optado por desbastar en 3 ejes, posicionando en 4 o 6 angulos distintos el 4to eje, y luego si terminar la pieza con mecanizado de 4 ejes continuos. Se me complica a la hora de hacer éste terminado.

    El mecanizado parte de una pieza previamente torneada, no hay problema por eso (adjunto la pieza en bruto, y la pieza terminada).

    http://www.megaupload.com/?d=BOMB0ZWM

    Se me complica mucho a la hora de terminar la pieza, pulirla, con una herramienta con radio. No logro comprender que debo seleccionar como rasgo, la estrategia que debo elegir, etc. He probado con casi todo, pero siempre hace cosas medias locas...

    Agradecería consejos, soluciones, o lo que se pueda respecto a esta pieza puntual! Tengo que mecanizarla realmente, y aún no puedo hacer el programa!

    Saludos!!! Muchisimas gracias!!!

    Andrés N. Fernández
    • 0

    #2
    flanaghan

    flanaghan

      WEBMASTER

    • Administradores
    • 5.514 Mensajes
  • Auxis: 233
    • Pais: Country Flag
    Hola Andrés

    en la pestaña patrón tienes puesto espiral, ponle zig

    en la pestaña retrocesos tienes puesto plano en Z, ponle cilindro en X

    en la pestaña acabado, tilda extender o trimar y métele un 100% en entrada y salida

    nos cuentas a ver que tal ahora

    • 0

    La teoría es algo que no se ve.
    ......porque el conocimiento pertenece al mundo y te hará libre
    un saludo


    Awards Bar:

    Users Awards

    #3
    Andrés

    Andrés

      Principiante en AuxCAD

    • Miembros
    • 6 Mensajes
  • Auxis: 0
    Un millón de gracias Flanaghan! Va mejorando la cosa...

    Les cuento que ya se ve mejor todo, he agregado el desbaste desde 4 ángulos distintos y posteriormente el acabado en 4 ejes de movimiento contínuo con la freza redonda con las modificaciones que me dió Flanaghan!

    El principal problema que encuentro es que aún no lo hace del todo bien al pulido, por un par de choques que tiene la freza, donde saca material que no debería, y por otro lado, no intenta hacer el radio de la parte superior de la hélice!

    Otra cosa que me gustaría tener opinión, es respecto al desbaste de la pieza, ya que desde mi punto d vista, toma mucho tiempo. Me intriga saber si a alguien se le ocurre una forma mejor de hacerlo...
    Más allá del tiempo, da vueltas medias locas (me gustaría algo mas prolijo) y estaría bueno que entre desde fuera del material, paralelo al eje Y, de forma que no pase tan cerca del plato del 4to eje que sujeta la pieza y ahorraría el tiempo de bajar en rampa.

    Acá va el link del mecanizado con todas las modificaciones:
    http://www.megaupload.com/?d=RGXXPU10

    Sinceramente agradezco la ayuda que me están brindando!!! Prometo hacer otro curso para saber usar el programa y poder ayudar yo!!!

    Saludos!

    Andrés
    • 0

    #4
    flanaghan

    flanaghan

      WEBMASTER

    • Administradores
    • 5.514 Mensajes
  • Auxis: 233
    • Pais: Country Flag
    Hola Andrés

    la calidad superficial viene vinculada con el paso o cresta, le estás metiendo una cresta de 0.05 con bola de 12, 1.5mm de paso, cuando para un acabado lo normal es 0,001 de cresta

    por otro lado  en multiejes tienes una pestaña de chequeo de colisión,  actívala y chequea al menos las partes de la hta, esto deberías hacerlo como normal general

    nos cuentas


    • 0

    La teoría es algo que no se ve.
    ......porque el conocimiento pertenece al mundo y te hará libre
    un saludo


    Awards Bar:

    Users Awards

    #5
    Andrés

    Andrés

      Principiante en AuxCAD

    • Miembros
    • 6 Mensajes
  • Auxis: 0
    Muchisimas gracias Flanaghan! Apenas llegue a casa pruebo, subo los archivos y vemos los cambios!

    Realmente así se aprende mejor que toqueteando todo! Jaja.

    Me queda una duda: ¿Hay forma de controlar mejor la entrada de la herramienta? ¿se podria hacer que entre paralelo al eje Y?

    Espero que al resto le sirvan estas consultas tanto como amí!!! Saludos a todos!

    Andrés
    • 0

    #6
    Andrés

    Andrés

      Principiante en AuxCAD

    • Miembros
    • 6 Mensajes
  • Auxis: 0
    Buenos días a todos!

    Subo un ZIP con la última versión de ésta pieza mecanizada con 4 ejes (con 4 giros discretos del 4to eje para el desbaste) y luego pulido con movimientos continuos de los 4 ejes...

    Creo que aún hay cosas para mejorar, pero ya está aceptable! ¡A alguien se le ocurre como mecanizar el radio superior de las hélices de forma helicoidal, es decir, la herramienta moviendose en el eje X, con el 4to eje girando? Sinceramente no lo pude hacer así, por lo cual, lo dejé con pasadas paralelas a Y, donde gira el 4to eje y la herramienta sube y baja...

    ¿Se les ocurre alguna otra estrategia para que el desbaste sea mas ordenado?

    Acá va el link: http://www.megaupload.com/?d=HT27M3C8

    Gracias por la ayuda!!!

    Andrés
    • 0

    #7
    Andrés

    Andrés

      Principiante en AuxCAD

    • Miembros
    • 6 Mensajes
  • Auxis: 0
    Buenas tardes de nuevo gente!

    Escribo para hacerles una última consulta. Intenté mecanizar la pieza en cuestión.

    La parte de desbaste, con 4to eje indexado, anduvo perfecto, da vueltas que a primera vista parecen innecesarias y rebuscadas, pero en fin, anda, y sirve.

    La parte del pulido, no pude hacerla! A pesar de que cuando hago la simulación de máquina, la pieza gira perfectamente, y se ve todo hermoso, cuando lo postproceso, la herramienta intenta bajar por debajo del eje de rotación, es decir, la pieza gira, pero a su vez, la herramienta se va moviendo en el eje X, Y y Z describiendo una hélice. Sinceramente me desconcertó mucho, tuve que frenar la máquina para no romper todo. Todavía no decifro si es cuestión del postprocesador o alguna opción del CamWorks en la que he metido la pata!!!

    Los archivos están subidos en las entradas anteriores!

    Agradecería ayuda de cualquiera que sepa del tema!!!

    Saludos y muchisimas gracias!!!
    • 0

    #8
    RAMIRO

    RAMIRO

      Experto en AuxCAD

    • Miembros
    • 133 Mensajes
  • Auxis: 8
    • Pais: Country Flag
    Hola que tal andres, a mi me paso algo muy similar cuando quise hacer 4 ejes el tema, luego de muchisimo renegar fue finalmente el archovo .KIM en donde se define donde y como esta dado el giro de los ejes angulares, o sea si es que gira el husillo o gira la pieza, si hay desplazamientos entre el 4to y 5 eje etc.

    Fijate en este post, en el que me ayudo muchisimo flanaghan y pude resolver el problema y realizar la pieza con exito.

    http://www.auxcad.co...hp?topic=8368.0

    saludos
    • 0

    #9
    Andrés

    Andrés

      Principiante en AuxCAD

    • Miembros
    • 6 Mensajes
  • Auxis: 0
    Muchimias gracias Ramiro!

    Me leí todo tu post y veo que tenía el mismo problema que tengo yo! Les explico donde tengo el problema ahora:

    Nunca compré un postprocesador, debido a que con el tutorial que viene predeterminado con CamWorks, siempre me ha andado perfecto con 3 ejes (el centro es un HAAS VF3 con 4to eje).

    Al editar el archivo .kim (del tutorial) que mencionan en tu post, aparentemente puedo solucionar el problema (analizando a grandes razgos el código generado). El problema es que la coordenada del eje A me la genera con 4 decimales, cosa que el centro de mecanizado no entiende, por lo tanto, no puedo ni simularlo ni ejecutarlo al programa en la máquina.

    Entiendo que eso se lo puede modificar con el UPG, pero el tutorial de Camworks no trae el archivo fuente .src.

    Si uso alguno de los postprocesadores que puedo conseguir en internet, viene con el .src, lo edito en el UPG, le cambio la cantidad de dígitos y todo bien por ese lado, pero no tienen el archivo .kim, por lo tanto sigo teniendo el problema de antes, es decir que intenta compensar algo moviendo el eje Y y Z además del A.

    Incluso he intentado ponerle el mismo nombre al archivo .kim (del tutorial) que el .ctl que usa CamWorks (al generado por UPG), pero cuando hago eso, el programa se genera sin ningún movimiento en el eje A.

    Alguna idea? Gracias a ambos!!!

    Es bueno saber que Flanaghan no es el único que se pone los post al hombro!!! Muchisimas gracias por la ayuda!!!

    Saludos!!!

    Andrés
    • 0

    #10
    RAMIRO

    RAMIRO

      Experto en AuxCAD

    • Miembros
    • 133 Mensajes
  • Auxis: 8
    • Pais: Country Flag
    tengo una solución fácil y una difícil para tu problema la fácil es retocar el programa a mano  con un programa como el EDITCNC que te puede recortar fácilmente la cantidad de cifras significativas simplemente vas a herramientas opciones y le pones los dígitos luego de la coma después escalas por 2 a todos los ejes y luego por 0.5 para volverlos a su valor.

    La dificil (por lo menos para mi que no la tengo tan clara) es retocar el post procesador con el UPG por ahi tardas un poco en sacarlo pero si lo vas a usar seguido al cuarto eje te combiene seguir este camino hasta que te quede de 10.

    saludos
    • 0

    #11
    CesarValde

    CesarValde

      Principiante en AuxCAD

    • Miembros
    • 1 Mensajes
  • Auxis: 0
    • Pais: Country Flag

    Hola que tal andres, a mi me paso algo muy similar cuando quise hacer 4 ejes el tema, luego de muchisimo renegar fue finalmente el archovo .KIM en donde se define donde y como esta dado el giro de los ejes angulares, o sea si es que gira el husillo o gira la pieza, si hay desplazamientos entre el 4to y 5 eje etc.

    Fijate en este post, en el que me ayudo muchisimo flanaghan y pude resolver el problema y realizar la pieza con exito.

    http://www.auxcad.co...hp?topic=8368.0

    saludos

    Sabe alguien donde puedo encontrar el post que mencionan, ya que intente acceder al link que esta aqui proporcionado y no me aparece nada, agradeceria mucho su ayuda ya que tengo el mismo problema.

     

    Saludos.


    • 0

    #12
    gen

    gen

      Iniciado en AuxCAD

    • Miembros
    • 32 Mensajes
  • Auxis: 1
    Buenas, me ocurre lo mismo, alguien puede ayudarnos a definir en el archivo .kim que lo que gira es la pieza y no la hta?
    • 0

    #13
    flanaghan

    flanaghan

      WEBMASTER

    • Administradores
    • 5.514 Mensajes
  • Auxis: 233
    • Pais: Country Flag
    Hola gen.

    Cuelga lo que tienes puesto en el archivo. Kin y de que máquina se trata

    Enviado desde mi D6603 mediante Tapatalk


    • 0

    La teoría es algo que no se ve.
    ......porque el conocimiento pertenece al mundo y te hará libre
    un saludo


    Awards Bar:

    Users Awards

    #14
    gen

    gen

      Iniciado en AuxCAD

    • Miembros
    • 32 Mensajes
  • Auxis: 1

    Hola gen.

    Cuelga lo que tienes puesto en el archivo. Kin y de que máquina se trata

    Enviado desde mi D6603 mediante Tapatalk

    Buenas Flana, gracias por tu rápida respuesta. 

     

    Te pongo en situación, la máquina es una fresadora casera con eje rotatorio paralelo al eje Y.

    Sería, creo, configuración table-table. Lo que he ido probando en el archivo .kin y como lo tengo ahora es así :

     

    0 * 5 Axis Type 0-TABLE_TABLE,1-HEAD_HEAD,2-HEAD_TABLE, 3-TABLE_TABLE_TOOLCOMP, 4-HEAD_HEAD_NOTOOLCOMP, 5-HEAD_TABLE_NOTOOLCOMP
    1 * XYZ Coordinate Type 0-Part , 1-Machine
    0.000000 * Spindle Direction X
    0.000000 * Spindle Direction Y
    1.000000 * Spindle Direction Z
    0.000000 * 1st Rotary Axis Direction X
    1.000000 * 1st Rotary Axis Direction Y
    0.000000 * 1st Rotary Axis Direction Z
    1.000000 * 2nd Rotary Axis Direction X
    1.000000 * 2nd Rotary Axis Direction Y
    0.000000 * 2nd Rotary Axis Direction Z
    0.000000 * Rotation Axis Base Point X  (Millimeters Only)
    0.000000 * Rotation Axis Base Point Y  (Millimeters Only)
    0.000000 * Rotation Axis Base Point Z  (Millimeters Only)
    -100000.000000 * 1st Rotation Axis Limit Min
    100000.000000 * 1st Rotation Axis Limit Max
    -180.000000 * 2nd Rotation Axis Limit Min
    180.000000 * 2nd Rotation Axis Limit Max
    Mill_Tutorial * Default Machine Simulation
     
    La pieza en cuestión es una de prueba que viene con el camworks, en la simulación se ve correcto, pero en la máquina el eje z trata de mecanizar en z negativa, cuando lo que debería de hacer es subir en z para ir salvando la pieza y como mucho bajar en z cuando la parte curva queda normal al eje z. Es decir, lo que interesa es que gire la pieza y la hta en z suba y baje.
    He probado a hacer un postprocesador y tampoco lo consigo así....
     
    Si necesitas el archivo de camworks me dices y lo subo a dropbox. 
     
    Muchas gracias por la ayuda porque me estoy volviendo loco ya !!! :$

    • 0

    #15
    gen

    gen

      Iniciado en AuxCAD

    • Miembros
    • 32 Mensajes
  • Auxis: 1
    Flana estás por ahí? Te necesito!
    He probado con cientos de post procesadores y ninguno hace lo que quiero... Lo mismo el problema lo tengo en la configuración del plan de operaciones... El caso es que el post sigue queriendo mover la herramienta en vez de girar la pieza
    • 0

    #16
    flanaghan

    flanaghan

      WEBMASTER

    • Administradores
    • 5.514 Mensajes
  • Auxis: 233
    • Pais: Country Flag

    Hola Gen

     

    si gira sobre el eje Y y la máquina es vertical el .kin debe ser así

     

     * 5 Axis Type 0-TABLE_TABLE,1-HEAD_HEAD,2-HEAD_TABLE, 3-TABLE_TABLE_TOOLCOMP, 4-HEAD_HEAD_NOTOOLCOMP, 5-HEAD_TABLE_NOTOOLCOMP
    1 * XYZ Coordinate Type 0-Part , 1-Machine
    0.000000 * Spindle Direction X
    0.000000 * Spindle Direction Y
    1.000000 * Spindle Direction Z
    0.000000 * 1st Rotary Axis Direction X
    1.000000 * 1st Rotary Axis Direction Y
    0.000000 * 1st Rotary Axis Direction Z
    1.000000 * 2nd Rotary Axis Direction X
    0.000000 * 2nd Rotary Axis Direction Y
    0.000000 * 2nd Rotary Axis Direction Z
    0.000000 * Rotation Axis Base Point X  (Millimeters Only)
    0.000000 * Rotation Axis Base Point Y  (Millimeters Only)
    0.000000 * Rotation Axis Base Point Z  (Millimeters Only)
    -180.000000 * 1st Rotation Axis Limit Min
    180.000000 * 1st Rotation Axis Limit Max
    -180.000000 * 2nd Rotation Axis Limit Min
    180.000000 * 2nd Rotation Axis Limit Max
    TableTable * Default Machine Simulation Name

     

    sino cuelga la pieza

     

    Un saludo


    • 0

    La teoría es algo que no se ve.
    ......porque el conocimiento pertenece al mundo y te hará libre
    un saludo


    Awards Bar:

    Users Awards

    #17
    gen

    gen

      Iniciado en AuxCAD

    • Miembros
    • 32 Mensajes
  • Auxis: 1

    Buenas Flana,

     

    He probado a cambiar esos valores en el archivo .kin y el postprocesado sigue sin ser bueno para mi.

    Si te fijas las coordenadas en Z son del orden de cientos, y aparte está postprocesando eje B.

     

    Me tiene loco el camworks !  :shok:  :shok:  :shok:  :shok:  :shok:  :shok:

     

    Adjunto captura de pantalla y el enlace donde está alojado el archivo de CADCAM.

     

    Enlace pieza: 

     

    https://www.dropbox....jes.SLDPRT?dl=0

     

     

    Aprovecho para hacer otra pregunta...no entiendo el concepto de  posición a cero grados  y los ejes implicados, podías explicarmelo un poco?

     

    Muchas gracias.

    Ficheros Adjuntos

    • Fichero Adjunto  4ejes.png   374,49K   2 Número de descargas

    • 0

    #18
    gen

    gen

      Iniciado en AuxCAD

    • Miembros
    • 32 Mensajes
  • Auxis: 1

    Flana !!!

     

    ¿ Lo doy por imposible ? 

     

    Llevo dos semanas con ello y no doy con la solución, si no se te ocurre nada intentaré hacerlo con el Aspire.

     

    Gracias.


    • 0

    #19
    flanaghan

    flanaghan

      WEBMASTER

    • Administradores
    • 5.514 Mensajes
  • Auxis: 233
    • Pais: Country Flag

    Hola Gen

     

    hay que tener muchas cosas claras antes de empezar a realizar operaciones de 3+2 o multiejes

     

    antes de hacer nada, tienes que crear un sistema de coordenadas, que coincida con tu eje de rotación y vincularlo a la máquina

     

    luego tienes que cerciorarte que los planos de trabajo en el arbol de operaciones estén apuntando/tlldados a ese eje de coordenadas, tanto en la pestaña origen como en la pestaña  eje

     

    pruebas y me comentas, te adjunto pantallazos

    Ficheros Adjuntos

    • Fichero Adjunto  1.png   20,35K   1 Número de descargas
    • Fichero Adjunto  2.png   19,14K   1 Número de descargas

    • 0

    La teoría es algo que no se ve.
    ......porque el conocimiento pertenece al mundo y te hará libre
    un saludo


    Awards Bar:

    Users Awards

    #20
    gen

    gen

      Iniciado en AuxCAD

    • Miembros
    • 32 Mensajes
  • Auxis: 1

    Hola Gen

     

    hay que tener muchas cosas claras antes de empezar a realizar operaciones de 3+2 o multiejes

     

    antes de hacer nada, tienes que crear un sistema de coordenadas, que coincida con tu eje de rotación y vincularlo a la máquina

     

    luego tienes que cerciorarte que los planos de trabajo en el arbol de operaciones estén apuntando/tlldados a ese eje de coordenadas, tanto en la pestaña origen como en la pestaña  eje

     

    pruebas y me comentas, te adjunto pantallazos

     

    Buenas Flana, 

     

    Por partes:

     

    -En el archivo que te subí no sé si es que se han perdido o qué, pero tengo un sistema de coordenadas que coincide con el sistema de coordenadas de la máquina en cuestión. Eje rotatorio paralelo al eje Y.   En mi caso la dirección de mecanizado respecto al sistema de coordenadas de amarre es NEGATIVO, es decir en mi máquina cuando hago un HOME se hace en Y+.

     

    -Cuando cambio a "sistema de coordenadas de amarre" en la pestaña EJE, me gira el sistema de coordenadas, en particular me cambia la dirección del eje Y.

     

    Cuando postproceso, mi mayor duda es la siguiente, veo que la coordenada Z llega a bajar hasta casi -30, lo que en máquina produce una colisión, no hay manera de que por ejemplo se mantenga fijo el Eje X y sea la pieza la que rote o que se le pueda limitar la Z y el software calcule automáticamente el giro?

     

    Cualquier configuración en el archivo .Kin no cambia este hecho.

     

    Soy un mar de dudas, muchas gracias por tu tiempo.

     

    Adjunto capturas de pantalla.

    Ficheros Adjuntos

    • Fichero Adjunto  1.jpg   87,03K   2 Número de descargas
    • Fichero Adjunto  2.jpg   97,1K   2 Número de descargas
    • Fichero Adjunto  3.jpg   84,09K   2 Número de descargas

    • 0




    0 Usuario(s) están leyendo este Tema

    0 miembro(s), 0 invitado(s), 0 usuario(s) anónimo(s)