Saltar al contenido

Foto

Ayudarme con el signo decimal de coma en excel o el guindous que me trae loco


  • Please log in to reply
11 Respuesta(s) a este Tema

#1
Joserra

Joserra

    Gurú en AuxCAD

  • Miembros
  • 542 Mensajes
  • Auxis: 88
    • Pais: Country Flag
    Hola. a ver si me podeis ayudar por favor:

    Estoy en un excel, y pongo un numero multiplicado por otro

    pongo

    2.294 * 25.4

    ¿Que tengo que hacer para que me lo haga normal????

    Y me pone lo que se le sale de los coj....=58267.6

    No se, parezco nuevo...Estoy muy enfadado, disculpar

    en la configuracion del windows tengo puesto simbolo decimales (.) punto
    y separador de miles (.) tambien


    Es eso o es que yo soy muy bruto con el excel, a este le tengo puesto formato de celda numero y con decimales


    • 0

    Awards Bar:

    Users Awards

    #2
    qwerty1735

    qwerty1735

      Experto en AuxCAD

    • Miembros
    • 70 Mensajes
  • Auxis: 16
    • Pais: Country Flag
    Hola Joserra!

    El Excel coge los decimales con la coma, los puntos son para miles  ;)

    A mi también me ha dado sustos muchas veces  :D

    Saludos!
    • 0

    #3
    Joserra

    Joserra

      Gurú en AuxCAD

    • Miembros
    • 542 Mensajes
  • Auxis: 88
    • Pais: Country Flag
    Gracias Qwerty, pero entonces...

    yo tengo que pone 2 (coma)294 asi.........

    Modifico el post: a ver, he cambiado la configuracion del windous a simbolo decimal coma

    y si pongo los numeros asi (con coma) el excel si multiplica bien. Gracias

    Pero no me gusta es una lata por que la mayor parte de los datos que nos circulan por hay a todos son con formato decimal en (punto) y tendria que andar haciendo cosas raras con los originales, como reemplazarles el punto...aparte de que es mas comodo utilizar el teclado con el grupo de teclas de la derecha.

    Bueno...si sabeis algo nuevo decirmelo por que ufff no me gusta, gracias no obstante
    • 0

    Awards Bar:

    Users Awards

    #4
    astemar

    astemar

      Gurú en AuxCAD

    • Miembros
    • 1.329 Mensajes
  • Auxis: 0
    • Pais: Country Flag
    En Excel 2007

    Vas a "Opciones de Excel" (primer icono esquina superior izquierda)

    En la pestaña "Avanzadas" marcas la opción "Usar separadores del sistema".

    Ahora usará los separadores que tengas asignados en Windows.

    Saludos.
    • 0
    HP Pavilion, Procesador Intel Core Duo a 2'4 Ghz, Ram 4 Gb, NVIDIA GeForce 9200M GS, Windows 7 Home Premium y SE ST2

    #5
    Joserra

    Joserra

      Gurú en AuxCAD

    • Miembros
    • 542 Mensajes
  • Auxis: 88
    • Pais: Country Flag
    Gracias Astemar tambien, el caso es que lo tengo asi tanto en la configuracion del windows como el excel

    Solo me ha funcionado cuando en la configuracion del idioma (en el panel de control, ya sabeis) he cambiado el separador decimal por coma

    pero sigue sin gustarme. Entenderme yo quiero usar el punto.

    Pregunta indiscreta por favor:

    Tu como tienes todo esto que hablamos?
    • 0

    Awards Bar:

    Users Awards

    #6
    astemar

    astemar

      Gurú en AuxCAD

    • Miembros
    • 1.329 Mensajes
  • Auxis: 0
    • Pais: Country Flag
    En Excel como te he dicho.

    En Windows Vista, Panel de control, Configuración regional y de idioma
    Formato número, simbolo decimal = punto, Separador de miles = coma

    Lo mismo en formato moneda.

    Saludos.
    • 0
    HP Pavilion, Procesador Intel Core Duo a 2'4 Ghz, Ram 4 Gb, NVIDIA GeForce 9200M GS, Windows 7 Home Premium y SE ST2

    #7
    Joserra

    Joserra

      Gurú en AuxCAD

    • Miembros
    • 542 Mensajes
  • Auxis: 88
    • Pais: Country Flag
    OK ahora lo he entendido, y me sale.

    Finalmente lo he dejado asi, un poco diferente y espero no arrepentirme Je Je ;):
    CONFIGURACION PANEL DE CONTROL-Configuracio regional y idioma
    Tanto numeros como moneda en separador decimal (coma) y en separador de miles (punto)

    Y EN EXCEL OPCIONES Le desmarco que no coja la configuracion del guindous y dejo:
    tanto decimales como miles (punto)

    Asi como lo tengo Cuando tengo que escribir un numero decimal en una celda uso el punto (Y es mas cómodo con el teclado númerico de la derecha).

    Ademas da igual que teclee .294 ó 0.294 pues el siempre se lo traga como un número decimal, y bueno..por curiosidad ya sabeis que el excel distingue los números alineandolos a la derecha de la celda

    GRACIAS ;D ;D ;D a ambos ;)

    Vuelvo a mis labores, y perdonarme que no haga mucho por el foro ultimamente, es que estoy con una montaña de trabajos pequeños pendientes que tenia abandonados.
    • 0

    Awards Bar:

    Users Awards

    #8
    astemar

    astemar

      Gurú en AuxCAD

    • Miembros
    • 1.329 Mensajes
  • Auxis: 0
    • Pais: Country Flag
    Pues bueno, si te funciona, perfecto.

    Saludos.
    • 0
    HP Pavilion, Procesador Intel Core Duo a 2'4 Ghz, Ram 4 Gb, NVIDIA GeForce 9200M GS, Windows 7 Home Premium y SE ST2

    #9
    qwerty1735

    qwerty1735

      Experto en AuxCAD

    • Miembros
    • 70 Mensajes
  • Auxis: 16
    • Pais: Country Flag

    Y EN EXCEL OPCIONES Le desmarco que no coja la configuracion del guindous y dejo:
    tanto decimales como miles (punto)

    Asi como lo tengo Cuando tengo que escribir un numero decimal en una celda uso el punto (Y es mas cómodo con el teclado númerico de la derecha).


    Hola Joserra!

    Me alegro de que te funcione!

    Pero una cosa, ¿como diferencia en cada caso Excel si el punto es separador de miles o decimales? Por ejemplo, 123.456,789 ¿como lo haría? ¿123.456.789? ¿No te lo cogería como millones?  ???

    Saludos!
    • 0

    #10
    Joserra

    Joserra

      Gurú en AuxCAD

    • Miembros
    • 542 Mensajes
  • Auxis: 88
    • Pais: Country Flag
    Tienes razon Qwerty

    Hago una nueva prueba asi:

    CONFIGURACION PANEL DE CONTROL-Configuracio regional y idioma
    Tanto numeros como moneda en separador decimal (coma) y en separador de miles (punto)

    Y EN EXCEL OPCIONES (cambio de opinion) Le dejo que coja la configuracion del windows

    si con este cambio, escribo comas 123456.789 lo hace como numero y deja 123456,7890

    si escribo punto 1234656.789 lo deja igual con decimales

    Es decir si escribo yo, bien

    ---

    Pero si importo este archivo de texto
    123456,789 decimales coma
    123.456,789 decimales coma
    123456.789 decimales punto

    Deja el ultimo (el de punto) en millones

    ya no se que hacer chicos, solo se que en muchas ocasiones los datos con decimales con los que muchas veces trabajamos vienen como punto, y es normal que sea asi.
    Supongo que es por que antes cuando no habia ordenadores estaba bien, pero claro ahora se usan teclados y PCs, y es mas comodo escribir el punto.

    La lata es que si quieres importar un archivo de texto que tenga decimales y te despistas asi...



    PD administrador: No puedo poner una foto directamente por que al parecer ya no se permite, imagino que habra que subir a un servidor de fotos, me lo confirmais? no tengo inconveniente, aunque echare de menos la antigua manera pues para fotos pequeñas es mas agil de visualizar directamente en el post.
    • 0

    Awards Bar:

    Users Awards

    #11
    qwerty1735

    qwerty1735

      Experto en AuxCAD

    • Miembros
    • 70 Mensajes
  • Auxis: 16
    • Pais: Country Flag
    Hola Joserra!

    Creo que le estamos dando demasiadas vueltas, y como decía un profesor mío, "el árbol nos está impidiendo ver el bosque"  :D

    Básicamente lo que quieres es que los decimales se separen mediante punto ¿no? Ya sea para importar datos, coordenadas, lo que sea.... Bien, pues entonces es imprescindible que en Excel el separador decimal lo definas como punto. Ahora bien, ¿quieres definir también los millares? Pues no queda más remedio que usar la coma, ya que si usas el mismo símbolo para las dos cosas (el punto) pueden existir contradicciones (como el ejemplo que te ponía en el anterior post).

    Otro ejemplo, si quieres poner 25,400 (decimal), ¿como lo pondrías en Excel? ¿25.400? ¿Quien te asegura que no lo coge como millares? Si la parte decimal fuese de 1, 2 o 4 cifras no creo que hubiese problema, ya que no se puede hacer millares y se daría cuenta, pero si ese número de cifras fuese múltiplo de 3 ahí sí que tendrías problemas, ya que no distinguiría si es una cosa u otra. Esto mismo es lo que te pasa en el último caso que pones.

    No se si me he explicado bien.

    Si tienes alguna duda o me he equivocado en algo no dudes en comentarlo!  ;)

    Saludos!
    • 0

    #12
    aer73

    aer73

      Gurú en AuxCAD

    • Miembros
    • 640 Mensajes
  • Auxis: 64
    • Pais: Country Flag
    -
    • 0




    0 Usuario(s) están leyendo este Tema

    0 miembro(s), 0 invitado(s), 0 usuario(s) anónimo(s)