Saltar al contenido

Foto

G41 y G42 , no me compensa !!


  • Please log in to reply
3 Respuesta(s) a este Tema

#1
bartqui

bartqui

    Experto en AuxCAD

  • Miembros
  • 136 Mensajes
  • Auxis: 11
    • Pais: Country Flag
    Hola , el otro día programando un contorno sencillo , intente compensar el radio de herramienta con G41 y no me lo cogia , la herramienta se movía como si no compensará ..
    Hay que decir que yo siempre programe en fanuc.

    Hay algún código especial o se programa de manera diferente al normal de iso ??

    G90 G1 G41 x_ y_ F600 (creo que la D no hace falta definirla en sinumerik , ya está de antes )

    Muchas gracias
    • 0

    #2
    ortizrh

    ortizrh

      Experto en AuxCAD

    • Miembros
    • 64 Mensajes
  • Auxis: 1
    • Pais: Country Flag

    Hola , el otro día programando un contorno sencillo , intente compensar el radio de herramienta con G41 y no me lo cogia , la herramienta se movía como si no compensará ..
    Hay que decir que yo siempre programe en fanuc.

    Hay algún código especial o se programa de manera diferente al normal de iso ??

    G90 G1 G41 x_ y_ F600 (creo que la D no hace falta definirla en sinumerik , ya está de antes )

    Muchas gracias

     

     

    Hola Bartqui

     

    Tienes que configurar en la maquina el radio de la herramienta para que te compense, la D es para compensar la longitud en ese caso usar D1

     

    Es importante al llamar la herramienta poner el nombre correctamente como este dada de alta en la maquina. 

     

    Te pongo una foto de ejemplo.

     

    ;Start of Path
    ;
    ;TECHNOLOGY: METHOD
    ;TOOL NAME : FAST_50.8_R3.00
    ;TOOL TYPE : Milling Tool-5 Parameters
    ;TOOL DIAMETER     : 50.800000
    ;TOOL LENGTH       : 100.000000
    ;TOOL CORNER RADIUS: 3.000000
    ;
    ;Intol     : 0.010000
    ;Outtol    : 0.010000
    ;Stock     : 0.000000
    ;
    ;Operation : DESBASTE_PLANEADO_BTM_COPY
    ;
    SUPA G0 Z-1.0 D0
    ;First Tool
    T="FAST_50.8_R3.00"
    M6
    G17
    ;Initial Move
    CYCLE832(0.005,3,1)
    G54
    G0 G90 X-443.22 Y0.0 Z10. S1441 D1 M3
    ;Approach Move
    Z5.
    ;Engage Move
    ;G1 G41 X____Y____F____

     

     

    Pruebas... y comentas.

     

    Saludos.

    Ficheros Adjuntos


    • 0

    #3
    bartqui

    bartqui

      Experto en AuxCAD

    • Miembros
    • 136 Mensajes
  • Auxis: 11
    • Pais: Country Flag

    Hola Bartqui

    Tienes que configurar en la maquina el radio de la herramienta para que te compense, la D es para compensar la longitud en ese caso usar D1

    Es importante al llamar la herramienta poner el nombre correctamente como este dada de alta en la maquina.

    Te pongo una foto de ejemplo.

    ;Start of Path
    ;
    ;TECHNOLOGY: METHOD
    ;TOOL NAME : FAST_50.8_R3.00
    ;TOOL TYPE : Milling Tool-5 Parameters
    ;TOOL DIAMETER : 50.800000
    ;TOOL LENGTH : 100.000000
    ;TOOL CORNER RADIUS: 3.000000
    ;
    ;Intol : 0.010000
    ;Outtol : 0.010000
    ;Stock : 0.000000
    ;
    ;Operation : DESBASTE_PLANEADO_BTM_COPY
    ;
    SUPA G0 Z-1.0 D0
    ;First Tool
    T="FAST_50.8_R3.00"
    M6
    G17
    ;Initial Move
    CYCLE832(0.005,3,1)
    G54
    G0 G90 X-443.22 Y0.0 Z10. S1441 D1 M3
    ;Approach Move
    Z5.
    ;Engage Move
    ;G1 G41 X____Y____F____


    Pruebas... y comentas.

    Saludos.


    • 0

    #4
    bartqui

    bartqui

      Experto en AuxCAD

    • Miembros
    • 136 Mensajes
  • Auxis: 11
    • Pais: Country Flag
    Hola , muchas gracias por la explicación y por tu tiempo ,
    El control de la máquina es diferente al de la foto.
    Lleva un 840d y la programación que yo hago también difiere un poco , la herramienta yo la defino así :
    T1
    M6
    Supongo que con esto basta , en el tooloffset tengo ya cargado la longitud y el radio creo que bien .. También le defino en las primeras líneas del programa el D1 como has visto .. No se
    Y mi programación es sin ciclos . Al venir de Fanuc me cuesta adaptarme .. Ya pondré una foto cuando pueda y me aseguraré de que este todo como dices !!

    Una vez más gracias por contestar !!
    • 0




    0 Usuario(s) están leyendo este Tema

    0 miembro(s), 0 invitado(s), 0 usuario(s) anónimo(s)